contador de visitas

Problemas con Instalación

Instalación, actualizaciones, aplicación de mods... Todo lo que necesitas saber sobre los Foros phpBB para gestionarlos en tu sitio web.

Moderadores: fabriciano, randy

camilo_1392
Veterano
Mensajes: 52
Registrado: 27-01-2006 01:53

Mensajepor camilo_1392 » 09-02-2006 04:53

fabriciano escribió:Eso significa que en la instalación no se han escrito los datos en config.php, tal como te he dicho en el mensaje anterior. En algunos servidores no es necesario cambiar los atributos de los archivos para que se pueda escribir en ellos, pero en otros si.

A pesar de que el archivo no ha sido creado puedes hacerlo tu, con el Bloc de notas, basándote en lo que te dí en el anterior mensaje, y subirlo a tu servidor.

Un saludo.


gracias tdo a sido solucionado :wink:

Avatar de Usuario
fabriciano
Administrador
Mensajes: 10379
Registrado: 04-09-2001 16:34
Ubicación: Lugo
Contactar:

Mensajepor fabriciano » 09-02-2006 10:33

Me alegro. ¡Suerte!
Fabriciano González González
Webmaster de Batiburrillo.net

Avatar de Usuario
magnificus
Senior
Mensajes: 34
Registrado: 27-10-2005 11:42

mysql

Mensajepor magnificus » 28-02-2006 08:18

Hola Fabricio y cia.
hace tiempo que os moleste con algo parecido, pero cada vez que monto un foro tengo problemas distintos. Estoy instalando un foro con Windows 2003 server + php + mysql + phpbb2. La instalación del servidor web fue sin problemas, php tambien funciona, pero cuando instalo mysql empiezan los problemas. Tras la instalación de mysql, aparece en la barra de estado un icono como un semáforo (en verde). El problema es cuando intento verificar que el servidor mysql funciona; ejecuto la instrucción "telnet xx.xx.xx.xx 3306" y me da el siguiente error: Host xx.xx.xx.xx is not allowed to connect to this MySQL server". He probado ejecutandola desde el servidor donde lo estoy instalando y con permisos administrativos, y desde otro ordenador, pero el mensaje es el mismo.
Alguien me podría hechar una mano.. (prometo que os la devuelvo)
Rafael Gutiérrez Olivar
http://www.infra.upm.es
adg.infra.upm.es
master.infra.upm.es

Avatar de Usuario
fabriciano
Administrador
Mensajes: 10379
Registrado: 04-09-2001 16:34
Ubicación: Lugo
Contactar:

Mensajepor fabriciano » 28-02-2006 18:42

No he trabajado con Windows Server 2003 y MySQL pero, por lo que tengo entendido, para que el servidor y la base de datos conecten es necesario instalar el driver ODBC.

Cuando lo instales tendrás que seguir la ruta Inicio \ Configuración \ Panel de control \ Fuentes de datos ODBC 32 bits para configurar la conexión. Deberás cubrir los datos siguientes:

    Windows DSN name: Nombre de la fuente de datos que estará disponible desde Windows.
    Mysql host (name or IP): Nombre o dirección IP del ordenador donde se encuentra instalado el servidor MySQL.
    Mysql Database Name: Nombre de la base de datos.
    User: Nombre de usuario de la base de datos.
    Password: Contraseña del usuario.
    Port: Puerto en el que se encuentra el servidor Mysql. Habitualmente es el 3306.

Un saludo.
Fabriciano González González
Webmaster de Batiburrillo.net

nazareno
Junior
Mensajes: 6
Registrado: 30-10-2006 07:56

Mensajepor nazareno » 30-10-2006 08:17

bueno ante todo quiero dar la gracias me lei el post de punta a punta y he solusionado casi todos los errores que cometi y los que no cometi yo....
pero como lei por aca ..siempre hay un pero..
y es muy coruioso.. o por lo menos para mi
cuento:
intale el foro como coresponde (o eso creo yo)hasta que no me dio nungun error!!
luego borre las carpetas que me padia borrar
dicha peticion aparecia en el index de mi foro que decia asi:
Asegurate de borrar los directorios install/ y contrib/ del servidor. Es muy importante por razones de seguridad y deberías hacerlo ya mismo por FTP o gestor de archivos

que chice los borre!!!
hice bien?? bueno no!
luego de borralos actualiza la pagina y me aprecio esto
Warning: main(): Unable to access ./includes/constants.php in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(./includes/constants.php): failed to open stream: No such file or directory in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(): Failed opening './includes/constants.php' for inclusion (include_path='.:/data/apache/php/mmp_lib') in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(): Unable to access ./includes/template.php in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(./includes/template.php): failed to open stream: No such file or directory in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(): Failed opening './includes/template.php' for inclusion (include_path='.:/data/apache/php/mmp_lib') in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(): Unable to access ./includes/sessions.php in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(./includes/sessions.php): failed to open stream: No such file or directory in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(): Failed opening './includes/sessions.php' for inclusion (include_path='.:/data/apache/php/mmp_lib') in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(): Unable to access ./includes/auth.php in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(./includes/auth.php): failed to open stream: No such file or directory in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(): Failed opening './includes/auth.php' for inclusion (include_path='.:/data/apache/php/mmp_lib') in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(): Unable to access ./includes/functions.php in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(./includes/functions.php): failed to open stream: No such file or directory in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(): Failed opening './includes/functions.php' for inclusion (include_path='.:/data/apache/php/mmp_lib') in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(): Unable to access ./includes/db.php in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(./includes/db.php): failed to open stream: No such file or directory in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Warning: main(): Failed opening './includes/db.php' for inclusion (include_path='.:/data/apache/php/mmp_lib') in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 157

Fatal error: Call to undefined function: encode_ip() in /data/members/free/tripod/es/t/h/o/thor69ar/htdocs/foro/common.php on line 166

ahora que es esto?
si no encuentra o no puede acceder a los ficheros que antes estaban en la carpeta INCLUDES...
que hice? bueo subi la carpeta otra bes con todos sus ficheros dentro... pues lei en uno de estos posts que habeses no era nesesario borrarlos o por lo menos eso entendi yo luego de colocarlos.. que paso???
otra ves el mensaje que decia...
Asegurate de borrar los directorios install/ y contrib/ del servidor. Es muy importante por razones de seguridad y deberías hacerlo ya mismo por FTP o gestor de archivos
tons?
que hice mal???

nazareno
Junior
Mensajes: 6
Registrado: 30-10-2006 07:56

Mensajepor nazareno » 30-10-2006 08:34

y en cuanto al el MYsql no se si servira de ayuda pero hace ya muchos meses manosee el sglserver y tenia el mismo problema sol oque eran otros puertos -udp y -tcp no se podia conectar por que tenia un ruter y no estana habilitados dichos puertos los solusione habilitandolos... no eran problemas de contrafuegos ya que o usaba
repito, no se si sea de ayuda....

Avatar de Usuario
fabriciano
Administrador
Mensajes: 10379
Registrado: 04-09-2001 16:34
Ubicación: Lugo
Contactar:

Mensajepor fabriciano » 30-10-2006 15:32

¿Has borrado las carpetas install y contrib o también borraste la carpeta includes? Los errores que reportas en tu primer mensaje indican que has borrado la carpeta includes. Revisa lo que te digo y comprueba que la carpeta includes, con todo su contenido, está en el servidor.

El error no se debe a MySQL. No sé si posteriormente surgirá algún otro, pero actualmente es debido a lo que te explico en el párrafo anterior.

Un saludo.
Fabriciano González González
Webmaster de Batiburrillo.net

nazareno
Junior
Mensajes: 6
Registrado: 30-10-2006 07:56

Mensajepor nazareno » 31-10-2006 01:08

:oops: :oops: :oops: :oops: :oops: jeje sisis esso me pasa por apurado y no leer con atencion.. ya tengo mi forito!!! jijijiji
asias!! asias!!

Avatar de Usuario
fabriciano
Administrador
Mensajes: 10379
Registrado: 04-09-2001 16:34
Ubicación: Lugo
Contactar:

Mensajepor fabriciano » 31-10-2006 19:06

¡Suerte!
Fabriciano González González
Webmaster de Batiburrillo.net

nazareno
Junior
Mensajes: 6
Registrado: 30-10-2006 07:56

Mensajepor nazareno » 04-11-2006 02:29

jejeej bueno ya anda casi tid digo casi por que saltan uno u otro eror pero nada importante.. ya solusionare esos errores!! por lo pontro lede dejo mi pagina para que vena coo quedo!!!
http://usuarios.lycos.es/thor69ar
sol me queda modificar un poco el foro para que qeude mas a lo que es mi estilo!!
jijijij

pero bueno la razo n de este poste es las gracias!!!!! tremendamente agradecido ya que gracias a esta web he podido hacer lo que hice :roll: :roll:


Volver a “Foros phpBB (Versión 2)”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 3 invitados