WordPress

Actualización obligatoria en WordPress para hacerlo más seguro

jQuery es un archivo necesario en la mayoría de las instalaciones de WordPress. Si queremos que el sistema sea seguro, debemos tratar de tener la versión más reciente del archivo JS que corresponde a jQuery. Explicamos lo que se puede hacer para conseguirlo.

Actualización obligatoria en WordPress para hacerlo más seguro

WordPress, está demostrado, es el gestor de contenidos, el CMS, más utilizado en Internet. Sus altas prestaciones, arropadas en temas y plugins, hace que una gran cantidad de sitios web funcionen sobre esta plataforma.

Actualmente existen, a todos los niveles, notables riesgos de seguridad no solo para los que utilizan la red de redes sino también para los que gestionan uno o varios sitios web. Por ello hay que tratar, siempre que sea posible, el estar al día con el fin de evitar ataques contra la privacidad y otros aspectos.

A pesar de que WordPress se actualiza con frecuencia, añadiendo nuevas prestaciones y tapando posibles agujeros de seguridad, no siempre, los responsables de la plataforma, pueden realizar determinados cambios, ya que si lo hacen, muchos sitios web dejarían de funcionar.

¿Por qué no se actualiza jQuery?

El archivo jQuery es fundamental para el buen funcionamiento de la mayoría de las páginas web asentadas en WordPress. Ello no significa que la seguridad de la versión de este archivo JS no esté en entredicho. La causa de que no se actualice está, como ya hemos indicado, en que muchos sitios web trabajan sobre un tema o plantilla obsoletos y, además, tienen también activos algunos plugins que llevan tiempo sin ponerse al día.

Si accedemos al directorio que alberga dicho archivo en nuestra instalación de WordPress, podremos comprobar que la versión activa en estos momentos es la 1.12.4. Esta versión presenta notables vulnerabilidades que afectan a la seguridad, por lo que es conveniente cambiarla por una versión más reciente.

Aunque se pueden efectuar actualizaciones a mano, con retoques en el archivo functions.php del tema activo, lo mejor es recurrir a un plugin, que hace todo el trabajo por nosotros.

Instalar jQuery Updater

jQuery Updater actualiza jQuery a la última versión estable del archivo. Ello ayuda a tapar el posible agujero de seguridad que genera la versión instalada con el sistema WordPress. Además, este plugin también hace lo mismo con jQuery Migrate.

Para instalar y activar este plugin lo más sencillo es, desde el Panel de Administración de WordPress, acceder a Plugins -> Añadir nuevo y escribir en la caja de búsqueda jQuery Updater. El paso siguiente es harto conocido. Si tienes alguna duda, puedes leer Cómo instalar un plugin en WordPress.

Tras la activación de jQuery Updater no es necesario llevar a cabo ningún ajuste, el plugin se ocupa de todo. Lo que sí es conveniente es comprobar si todo funciona perfectamente, ya que puede haber problemas, tal como hemos indicado, con el tema activo y/o con algún plugin.

Acceso

Para conocer todas las características de este plugin hay que acceder a jQuery Updater. Si después de instalarlo y activarlo algo no funciona, basta con desactivarlo para que todo vuelva al estado anterior, ya que el plugin no reemplaza ningún archivo.

fabriciano

Amante de la informática y de Internet entre otras muchas pasiones. Leo, descifro, interpreto, combino y escribo. Lo hago para seguir viviendo y disfrutando. Trato de dominar el tiempo para que no me esclavice.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

Botón volver arriba